TeXnicCenter und Acrobat 8.1

Neue Frage »

Ari Auf diesen Beitrag antworten »
TeXnicCenter und Acrobat 8.1
Hey ihr,

wenn ich die Ausgabe im TeXnicCenter betrachten will, erhalte ich immer die Fehlermeldung "Beim Öffnen dieses Dokuments ist ein Fehler aufgetreten". Soweit ich nach Googeln weiß, liegts daran, dass der neue Reader die alten Befehle im Ausgabeprofil nicht versteht - hab nur eine Seite dazu gefunden und da wird auch nur geschrieben, dass auf Updates gewartet wird.

Seit gut ner Woche funktionierts nicht mehr, und so langsam möchte ich wieder normal damit arbeiten können..

Habe im Moment folgende Befehle (und schon mehrere ausprobiert):

code:
1:
2:
3:
4:
Projektausgabe betrachten: [DocOpen("%bm.pdf")][DocOpen("%bm.pdf")][FileOpen("%bm.pdf")]
Suche in Ausgabe: %bm.pdf
Vor Compilierung Ausgabe schließen: [DocOpen("%bm.pdf")][DocClose("%bm.pdf")]


Könntet ihr mir bitte weiterhelfen?
Calvin Auf diesen Beitrag antworten »

Kurz und knappe Antwort Augenzwinkern http://www.mrunix.de/forums/showthread.php?t=48082
 
 
Ari Auf diesen Beitrag antworten »

Hi nochmal,

tut mir leid, aber auch durch ändern der Befehle ändert sich nichts:

"Beim Öffnen dieses Dokuments ist ein Fehler aufgetreten. Die Syntax für den Dateinamen, Verzeichnisnamen oder die Datenträgerbezeichnung ist falsch."

Ich hab nichts anderes getan als ein Update von 8.0 auf 8.1 (der Link meint glaube ich 8.0). Der Pfad führt aber zum richtigen Reader.
Calvin Auf diesen Beitrag antworten »

Hm, dann kann ich dir leider nicht weiterhelfen unglücklich Ich habe weder TexnicCenter noch AcrobatReader 8.1 Ich habe nichtmal Windows Augenzwinkern

Bist du sicher, dass du keine Fehler beim Abtippen der Befehle gemacht hast? Oder hast du Copy&Paste gemacht?
Ari Auf diesen Beitrag antworten »

Ich habe Copy&Paste benutzt...

Hm schade, aber trotzdem danke! smile
tigerbine Auf diesen Beitrag antworten »

Was, wenn du einfach eine älter Acrobat Reader Version benutzt? verwirrt
Ari Auf diesen Beitrag antworten »

Gegen die Installation einer älteren Version von Acrobat Reader wehrt sich das Setup-Programm vehement.. unglücklich
keiner Auf diesen Beitrag antworten »

bei mir ging es erst auch nicht. aber wenn ich den [DocOpen("%bm.pdf")] befehl einmal wiederhole, ihn also 3mal schreibe, dann gehts.

--> [DocOpen("%bm.pdf")][DocOpen("%bm.pdf")][DocOpen("%bm.pdf")][DocClose("%bm.pdf")]
Schwein Auf diesen Beitrag antworten »

Hallo Leute
Ich hab das selbe Problem. Doch man kann es einfach umgehen, wenn ihr vor dem texen den Acrobat-Reader scho öffnet.
Ich weiss nicht wie ihr es seht, aber ich schliesse daraus, das ist es ein Link-Problem zum Acrobat-Reader ist.
Beste Grüsse
Trude Auf diesen Beitrag antworten »

Hi,

hab das selbe problem gehabt und bei mir war es tatsächlich ein Problem mit dem Link auf den Reader.
Hab unter Ausgabe -> Ausgabeprofil definieren -> viewer den Pfad neu eingestellt und jetzt funktioniert wieder alles.

Grüße
Neuer Auf diesen Beitrag antworten »

Bei mir hatte das alles nichts geholfen. Habe jetzt eine andere Lösung gefunden:
Bei Pafausgabe betrachten, einfach statt dem DDE-Kommando die Kommandozeile auswählen und dann %bm.pdf reinschreiben. Fertig
klausklaus Auf diesen Beitrag antworten »

Hatte auch das Problem das das pdf nicht angezeigt wurde!

ABER bei mir hatte es einen ganz anderen Grund!!!

Ich hatte den Namen des Kapitels umgeändert in den Namen " Inbetriebnahme"

Im Kapitel selbst war aber noch ein Pfad für ein Bild wo noch der alte Kapitelname
"{chapter7/Bilder/Testbild.png} stand !!!!
Habe "chapter7" gegen "Inbetriebnahme" ausgetauscht und nicht nur das Kompillieren funktionierte wieder sondern das pdf-Anzeigen auch wieder!
Kompilieren hatte vorher auch 0 Fehler gezeigt!?!


\chapter{Inbetriebnahme}

\label{ch:Inbetriebnahme}
.............................................

\begin{figure}
\centering
\includegraphics[width=1.00\textwidth]{Inbetriebnahme/Bilder/Testbild.png}
\caption{PV-Anlagenmuster}
\label{fig:Testbild}
\end{figure}
Ryuno-Ki Auf diesen Beitrag antworten »

Bin Latex-Neuling und wollte mir das daheim auch einmal ermöglich.
Zunächst einige technische Infos:
Windows Vista Home Basic, 32-Bit-Version (keine doofen Kommentare dazu, bitte -_-")
MikeTex 2.8 version 0.3
TeXnicCenter 1.0
Acrobat Reader 8.1.5

So, nun will ich eine ganz einfache Tex-Datei in PDF kompillieren (LateX => PDF)

\documentclass[12pt,onecolumn,a4paper,twoside]{article}

\usepackage[ngerman]{babel}
\usepackage[latin1]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[DIV15]{typearea}

\begin{document}
Body
\end{document}

und bekomme Fehlermeldung:

TeXnicCenter
[DocOpen("%bm.pdf")][FilecOpen("%bm.pdf")]
Der Befehl konnte nicht ausgeführt werden.

(abgetippt)

Was ich bisher versucht habe:
Unter Ausgabe ~> Ausgabeprofile definieren ... ~> Viewer
unter "Projektausgabe betrachten ..." beim (x) DDE-Kommando (wofür steht das eigentlich?) in der Kommandozeile die Option geändert zu:

[DocOpen("%bm.pdf")][DocOpen("%bm.pdf")][FileOpen("%bm.pdf")]

Keine Verbesserung.
Auch mit %bm.pdf als Kommandozeilenbefehl gab's nichts.

Acrobat Reader geöffnet und Kompillieren versucht, kein Ergebnis.

Ich hab auch etwas gelesen, dass man direkt über einen Kommandobefehl kompilieren versuchen sollte, weiß aber nicht, wie das geht.

Die Datei wird auch nicht in DVI oder PS konvertiert/kompilliert ...

Ich geb noch ein Log-File mit:
This is pdfTeX, Version 3.1415926-1.40.10 (mikTeX 2.8)
entering extended mode
(C:\Users\André\Desktop\Latex\AB1.tex <~ hat er vllt Probs mit dem é?
LaTeX2e <2009/09/24>
Babel <v3.81> and hyphenation patterns for english, dumylang, nohyphenat, german, ngerman, german-x-2009-06-19, ngerman-x-2009-06-19, french, loaded.
[...]
("C:\Program Files\Latex\MikTeX\tex\latex\base\tlenc.def"))pdflatex.exe: GUI framework cannot be initialized
I couldn't open file name: 'C:\Users\André\Desktop\Latex\AB1.aux <- ist auch nicht im Ordner (oder Unsichtbar?)
Couldn't find input file C:\Users\André\Desktop\Latex\AB1 nor C:\Users\André\Desktop\Latex\AB1.idx
Usage: C:\Program Files\Latex\MikTeX\miktex\bin\makeindex.exe [-ilqrcgLT] [-s sty] [-o ind] [-t log] [-p num] [idx0 idx1 ...]

LaTeX-Ergebnis: 0 Fehler, 0 Warnung(en), 0 zu volle/leere Box(en), 0 Seite(n)

Achja, Haken bei BibTex und MekeIndex sind auch nicht.

Wo liegt der Fehlerteufel?
Wäre für Hilfe echt dankbar.
Sonst muss ich immer in der Uni kompillieren ...

Hoffe, ich hab alle relevanten Informationen angegeben ...
Gruß

Ryu
Calvin Auf diesen Beitrag antworten »

Zitat:
("C:\Program Files\Latex\MikTeX\tex\latex\base\tlenc.def"))pdflatex.exe: GUI framework cannot be initialized


Du bist hiervon betroffen: Problem zwischen MikTeX und TeXnicCenter

Die DDE-Kommandos sind zur Steuerung des pdf-Viewers. Damit wird ihm z.B. gesagt, ob er ein evtl. geöffnetes Dokument vorher schließen soll bzw. mit welchen Parametern ein Dokument geöffnet wird.
Ryuno-Ki Auf diesen Beitrag antworten »

Jetzt müsste ich nur noch 'rausfinden, wo ich das bei MikTeX ändern kann ...
Also im Programm selber gibt es keinen Punkt "Optionen", unter dem ich Änderungen vornehmen könnte.
Muss ich das sonst noch einmal installieren oder ist das wenig sinnvoll?
Calvin Auf diesen Beitrag antworten »

Hier ist es mit Screenshots beschrieben http://www.matheboard.de/thread.php?thre...045#post1050747
dominik-deluxe Auf diesen Beitrag antworten »

also gleicher fehler, gescheite loesug

problem war ein foto, mit chrome runtergeladen, konnte techniccenter einfach nicht oeffnen. mit paint geoeffnet neu gesoeichert, geht.

so ne scheisse
snur Auf diesen Beitrag antworten »

Ich bin auch schon den ganzen vormittag dabei, Miktex und Technixcenter zum laufen zu bekommen. Meine Grundvoraussetzungen:
Technixcenter 1.0 RC1
Miktex 2.8
Acrobar Reader 9.4.0
Win XP

Auf meinem Laptop funktioniert das Kompilieren meiner tex Datei, nur auf dem Desktop nicht. Und das ist doof böse

Eine Fehlermeldung erhalte ich unter Technixcenter nicht (nur das bereits erwähnt GUI framework cannot be initialized.). Kompiliere ich das Projekt unter Texworks, wird eine pdf Datei erstellt, alles ist gut (aber es werden keine Packages installiert, wenn ich das richtig sehe). Gehe ich dann wieder in Technixcenter, kann ich zwar Kompilieren, angezeigt wird mir aber die pdf Datei, die von Texworks erstellt wurde. Wenn ich diese pdf Datei lösche, kann der Reader keine Datei darstellen und Technixcenter gibt mir die Fehlermeldung

Zitat:
[DocOpen("%bm.pdf")][DocOpen("%bm.pdf")]
Der Befehl konnte nicht ausgeführt werden.


Ich habe die Tipps eigentlich alle durch, ich habe alle Packages aktualisiert, Technixcenter nochmal neu installiert, Acrobat Reader aktualisiert, nichts bringt was... Kann mir jemand helfen?
snur Auf diesen Beitrag antworten »

Als Nachtrag vielleicht noch:

matheboard.de/thread.php?threadid=407060
Diese Tipps habe ich befolgt, On-the-fly steht aus Yes. Ich weiss nicht, welche Packages mir fehlen. Wie gesagt, es werden beim Kompilieren auch keine weiteren Packages installiert. eine log Datei würde ich gern einstellen, weiss jedoch leider nicht, wo ich diese finde Hilfe

Entschuldigt bitte meine Unwissenheit...
Calvin Auf diesen Beitrag antworten »

Die log-Datei entsteht beim Kompilieren automatisch. Sie befindet sich im selben Verzeichnis wie die .tex-Datei. Außerdem hat sie den selben Namen und die Endung .log

Am besten, du hängst diese Datei einem Beitrag an. Dann kann man genau sehen, ob Fehler sind.

Das Umstellen der Paketinstallation auf "Yes" hat bei mir im ersten Versuch übrigens auch nicht geholfen. Erst als ich Miktex komplett de- und neu installiert habe (mit der richtigen Einstellung), hat es geklappt.

Inzwischen bin ich aber sowohl von Texniccenter als auch von Miktex weg....

Texlive und Texworks leisten mir sehr gute Dienste.
Schweinebacke Auf diesen Beitrag antworten »

Zitat:
Original von Calvin
Texlive und Texworks leisten mir sehr gute Dienste.

TeXworks ist übrigens auch bei MiKTeX dabei und hilft dort ebenfalls, das Problem mit der nicht funktionierenden Installation von Paketen zu vermeiden. Einfach die Hauptdatei des Dokument einmal mit TeXworks öffnen und dort einen LaTeX-Lauf (je nach Wunsch latex oder pdflatex) starten. Danach geht es ggf. auch wieder mit TeXnicCenter, wenn man dieses unbedingt für die eigentliche Arbeit verwenden will.

Von TeXworks ist übrigens gerade erst eine neue Version erschienen. Ob es die bereits als Paket für MiKTeX gibt, weiß ich nicht . Ich verwende ebenfalls kein MiKTeX.

TeXworks hat übrigens auch einen internen PDF-Viewer, so dass übliche Probleme mit Adobe Reader, die nicht starten oder nicht automatisch das Dokument vor dem pdflatex-Lauf schließen ebenfalls vermieden werden können. In der neuen Version ist TeXworks auch mit synctex nutzbar.
snur Auf diesen Beitrag antworten »

Jetzt klappt es bei mir auch wieder. Ich habe sowohl Technixcenter als auch Miktex 2.8 komplett runtergeschmissen und neu installiert, bei miktek dann die fehlenden packages nachinstalliert und nun klappt es wieder. Woran es genau lag, weiß ich allerdings nicht.
Luthien88 Auf diesen Beitrag antworten »
LaTeX und Adobe Reader X
Für alle, bei denen die gegebenen Lösungen nicht geholfen haben:
Bei mir lags nicht am LateX oder an den Befehlen, sondern an einer Voreinstellung des Adobe Reader X.
Adobe Reader X starten-->Berabeiten--> Voreinstellungen--> Allgemein
Dort nehmt ihr das Häkchen bei "Geschützten Modus beim Start aktivieren" raus. Dann sollte alles wie gewohnt funktionieren. Ich hab etwa 20 Foren durchsucht, bis ich die Lösung gefunden habe und hoffe, ihr habt meinen Eintrag schneller gefunden!
Neue Frage »
Antworten »



Verwandte Themen

Die Beliebtesten »
Die Größten »
Die Neuesten »