hyperref-Link führt nicht zum Index, sondern direkt davor

Neue Frage »

Lampe16 Auf diesen Beitrag antworten »
hyperref-Link führt nicht zum Index, sondern direkt davor
Meine Frage:
Anklicken des als Link eingefärbten "Index" im Inhaltsverzeichnis führt nicht zum Index, sondern eine Seite davor. Was soltte ich ändern?
Ich benutze WinEdt5 und benutze
\usepackage[...]{hyperref} Version July 2003
als letztes Package.

Das Ende des tex-files sieht so aus:
...
\end{appendix}

\newpage
\addcontentsline{toc}{section}{Index}
\printindex
\end{document}

Meine Ideen:
Ich vermute, das ich mit dem \addcontentsline vielleicht kontraproduktiv eingreife, aber ohne erscheint der Index nicht im Inhaltsverzeichis.
Calvin Auf diesen Beitrag antworten »

Wenn du eine Komascript-Klasse nutzt (ist eh zu empfehlen), dann bekommt man durch eine Klassenoption das Indexverzeichnis ins Inhaltsverzeichnis

code:
1:
2:
3:
4:
5:
6:
7:
8:
9:
10:
11:
12:
13:
\documentclass[10pt,a4paper,index=totoc]{scrartcl}
\usepackage{makeidx}
\usepackage{hyperref}
\makeindex
 
\begin{document}
\tableofcontents
\newpage
Dies ist ein kurzer \index{kurz} Satz.\newpage
Die ist eine neue \index{neu} Seite.
\newpage
\printindex
\end{document}
 
 
Lampe16 Auf diesen Beitrag antworten »

Danke für den Tipp!

Ich habe bisher \documentclass[german,fleqn]{article} und hoffe, dass scrartcl die Formelsammlung mit vielen minipages nicht über den Haufen wirft.
Lampe16 Auf diesen Beitrag antworten »

Es wird nichts über den Hufen geworfen, texify und dvi->pdf laufen ohne Fehler, die Links sind vorhanden aber der Index ist nicht im toc.

Mein tex-file sieht jetzt so aus:

\documentclass[german,fleqn,index=totoc]{scrartcl}
\usepackage{amssymb}
\usepackage{makeidx}
\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{amssymb}
\usepackage{german}
\usepackage{graphicx}
\usepackage{textcomp} % für Promille
\usepackage{hyperref}
\makeindex

...

\begin{document}
...

\setcounter{tocdepth}{1}
\tableofcontents

...

\end{appendix}

\newpage
\printindex
\end{document}

Fehlt da noch etwas?
Lampe16 Auf diesen Beitrag antworten »

@Calvin
Es hat sich aufgelöst: statt " index=totoc" heißt die Option einfach "idxtotoc".
Damit geht es perfekt.

Jetzt würde ich die Links nur noch gerne blau statt schwarz haben. Gibt es dafür eine Option?

edit:
Ja, ist auch erledigt.
Calvin Auf diesen Beitrag antworten »

Zitat:
Original von Lampe16
@Calvin
Es hat sich aufgelöst: statt " index=totoc" heißt die Option einfach "idxtotoc".


Dann hast du noch eine alte Version von Komascript bzw. eine ältere oder nicht aktualisierte LaTeX-Distribution.
Lampe16 Auf diesen Beitrag antworten »

Ja, genau,Version July 2003! Aber jetzt läuft's. Danke!
Schweinebacke Auf diesen Beitrag antworten »
Nur ein paar Hinweise
Juli 2003 ist mit Sicherheit eine extrem alte KOMA-Script-Version. Ich würde empfehlen nach Abschluss des Projekts unbedingt die komplette TeX-Distribution zu erneuern. KOMA-Script hat in den letzten Jahren sehr viele neue Möglichkeiten hinzu gelernt und Fehler aus dieser alten Version wurden sicher auch behoben.

Bereits oder gerade bei dieser total veralteten KOMA-Script-Version, war \appendix keine Umgebung, sondern eine Anweisung, die wie ein Umschalter wirkt. Man konnte die Wirkung davon noch nie mit einer Umgebung komplett auf diese Umgebung beschränken.

BTW: \newpage ist vor \printindex normalerweise überflüssig. Da der Index intern mit \twocolumn zweispaltig gesetzt wird, beginnt er ohnehin auf einer neuen Seite.

Das Paket german ist übrigens für alte Rechtschreibung. Für die gültige Deutsche Rechtschreibung verwendet man entweder das Paket ngerman oder besser das Paket babel mit Option ngerman.
Lampe16 Auf diesen Beitrag antworten »
RE: Nur ein paar Hinweise
Danke für die Tipps!
Dass ich mit dieser alten Version arbeite, liegt daran, dass auch das Projekt nicht neu ist. Auch wenn ich überzeugter LATEXer bin, bin ich mir nicht sicher, ob aktuelle Versionen überall abwärtskompatibel sind.

Würdest du ein heute downgeloadetes LATEX auf ein bestehendes 500-Seiten Buch loslassen (Zentraldokment, hunderte Bilder, Tabellen, Makros ohne Ende u.s.w.)?
Ich schließe nicht aus, dass das "durchläuft". Aber ist das wahrscheinlich?

Bis zur Überzeugung vom Gegenteil: Never change a winning team.
Schweinebacke Auf diesen Beitrag antworten »
RE: Nur ein paar Hinweise
Wenn ich heute ein altes Buch wieder neu in Bearbeitung nehmen würde, würde ich das auf einem aktuellen LaTeX-System machen. Ab einem bestimmten Punkt der Bearbeitung - dieser kann je nach Aufwand des Projekt oder nach dessen Dringlichkeit sehr unterschiedlich sein und auch unmittelbar nach dem Update zu Beginn des Projekts, aber auch erst wenige Tage vor der geplanten Abgabe liegen - würde ich dann keine zentralen Pakete mehr updaten.

Ich würde jedoch nicht ein Buch nur deshalb mit altem Kram bearbeiten, nur weil der Kram bei der Ersterzeugung des Buches aktuell war. Ich habe mir vor einiger Zeit mal den Spaß gemacht, meine Studienarbeit von vor über 20 Jahren mit LaTeX2e und KOMA-Script statt dem damals aktuellen LaTeX2.09 und article.cls zu setzen. Das lief ohne Fehlermeldung durch und der Satz war sogar besser als damals. Weil da noch gnuplot-Grafiken drin waren, die damals als epic exportiert wurden, habe ich diese dann mit Gnuplot neu als pdf erzeugt und mit graphicx statt mit epic eingebunden. Damit konnte ich innerhalb von Minuten mit pdflatex ein pdf erzeugen. Ich hatte sogar das Glück, dass die geänderten, automatischen Seitenumbrüche alle verwendbar waren.

Bei KOMA-Script selbst wurden AFAIK keine (jedenfalls keine dokumentierten und bekannten) Anwenderanweisungen je entfernt. Der Umbruch kann sich geändert haben, wobei man auch das mit Hilfe der Option version=first (die wird übrigens automatisch verwendet, wenn man eine obsolete Option wie idxtotoc angegeben hat) auf ein Minimum reduzieren kann. AFAIK sind nur Satzfehler davon nicht betroffen. Auf den Umbruch wirken sich Änderungen bei anderen Paketen wie hyperref oder color vermutlich weit mehr aus.

Weil ich nicht weiß, wie Dein Projekt beschaffen ist, hatte ich extra das nach in meinem Beitrag sehr deutlich - nämlich aktiv - ausgezeichnet. BTW: Falls das alte Buch weiterhin in veralteter Rechtschreibung gesetzt werden soll, ist natürlich das Paket german oder das Paket babel mit Option german durchaus korrekt. Dann sollte ngerman weder geladen noch als Option gesetzt werden. Falls jedoch die Rechtschreibung auf einen wie auch immer gearteten aktuellen Stand gebracht werden soll, gilt mein Hinweis auf ngerman.
Lampe16 Auf diesen Beitrag antworten »
RE: Nur ein paar Hinweise
Zitat:
Original von Schweinebacke

Weil ich nicht weiß, wie Dein Projekt beschaffen ist, hatte ich extra das nach in meinem Beitrag sehr deutlich - nämlich aktiv - ausgezeichnet.


Es ist schon zum Verzweifeln: Die Betonung des nach hatte ich nicht realisiert. *) Pardon! Aber in meiner Gewichtung ist das der entscheidende Rat.

Für deine ausführlichen Kommentare nochmal vielen Dank.


*) Ein Chef rügte mich mal mit den Worten: "Es genügt nicht, wenn Sie mir eine Aktennotiz schicken. Sie müssen sie mir um die Ohren hauen."
Neue Frage »
Antworten »



Verwandte Themen

Die Beliebtesten »
Die Größten »
Die Neuesten »