Hilfe beim Kompilieren einer .tex Datei

Neue Frage »

antjeprincipessa Auf diesen Beitrag antworten »
Hilfe beim Kompilieren einer .tex Datei
Meine Frage:
Hallo, ich benutze Miktex und Texniccenter. Ich habe eine Vorlage für Tesxniccenter bekommen und möchte die jetzt als pdf ansehen. Ich habe diese gespeichert und nun will ich sie kompilieren. Das klappt und er zeigt mir keine Fehler an. Wenn ich nun F5 drücke, um sie mir als pdf anzusehen, sagt mir mein pdf-viewer, dass die Datei nicht gefunden werden konnte. Außerdem steht auch bei Texniccenter 0Seiten. Was mach ich falsch???

Meine Ideen:
Ich hab leider keine Ahnung. Nur das diese 0 Seiten falsch sind.
Calvin Auf diesen Beitrag antworten »

Mal ins Blaue geraten (und aus der Erfahrung wohl auch richtig geraten)...

[Lösung] "Plötzlich" wird keine pdf-Datei mehr erstellt. Habe MikTeX 2.8/2.9 und TeXnicCenter 1.0
 
 
antjeprincipessa Auf diesen Beitrag antworten »

Ja das war wohl der Fehler. Ich bin jetzt nach der Anleitung fortgefahren, aber nun zeigt er mir 3 Fehler an, obwohl vorher 0 Fehler waren. Ich hab echt keine Ahnung, was das jetzt soll und verzweifel hier grad total:-(
Calvin Auf diesen Beitrag antworten »

Die 0 Fehler von vorher kannst du vergessen. Da war ein ganz anderes Problem vorhanden und Texniccenter ist gar nicht dazu gekommen, irgendwelche anderen Fehler zu protokollieren.

Was für Fehler zeigt er denn an? Mit F9 kannst du von Fehler zu Fehler springen.
antjeprincipessa Auf diesen Beitrag antworten »

OK. ich nenne mal die Fehler. Kann damit leider nichts anfangen:-(
1. LaTex Error: File 'bbding.sty ' not found
Type X to quit or <Return>to proceed, or enter new name. (Default extension: sty)
Enter file name:
2. emergency stop
<read *>
1.8 \usepackage
{graphics,graphicx}
3. Fatal error occured, no output PDF file produced
Transcript written on ausarbeitung.log.

So das sind die Fehlermeldungen. Vielleicht kann mir ja jemand weiterhelfen. Ich bin völlig planlos.

Wie gesagt, die Datei besteht aus verschiedensten Einstellungen für die Ausarbeitung, sodass das Format immer gleich bleibt. Z.b. dass man Umlaute und Sonderzeichen direkt eingeben kann durch \usepackage[latin1]{inputenc}
oder \usepackage{amssymb} %sorgt dafür, dass Sie viele mathematische Zeichen zur Verfügung haben!
usw.
Möchte jetzt mit der Ausarbeitung anfangen und habe die Datei geöffnet. Kann sie aber nicht kompilieren, leider.
Calvin Auf diesen Beitrag antworten »

Das Paket bbding ist bei dir nicht installiert.

Wie hast du das vorherige Problem gelöst? Hast du die Miktex-Einstellungen geändert? Wenn ja, auf hast du "yes" ausgewählt? Oder hast du auf der Konsole kompiliert?

Schau dir im Zweifel nochmal diesen Beitrag an.

EDIT
Es bewahrheitet sich übrigens mal wieder, dass fertige Vorlagen gerade Anfänger alles andere als hilfreich sind. Meistens steht viel zu viel unnötiges (oder sogar veraltetes) Zeug drin. Viel sinnvoller ist es, zunächst mit einer "leeren" Präambel anzufangen und nur bei Bedarf neue Pakete hinzuzufügen.

Für den Anfang ist oftmals nicht viel mehr als folgendes notwendig

code:
1:
2:
3:
4:
5:
\usepackage[T1]{fontenc}
\usepackage[latin1]{inputenc} // oder ansinew, utf8
\usepackage[ngerman]{babel}
\usepackage{graphicx}
\usepackage{amsmath}
antjeprincipessa Auf diesen Beitrag antworten »

Also ich habe bei MikTex die Einstelliungen geändert und auf Yes geklickt. Das andere sah so kompliziert aus:-)
Ja das mit den Voreinstellungen ist so ne Sache, aber da unsere Professorin das genauso haben will, komme ich ja nun nicht drum herum:-) Ich schau mir gleich nochmal den Link an.

Mal so ne Frage. Nützt das eventuell, wenn ich die Datei mal hier hochlade????

LG
antjeprincipessa Auf diesen Beitrag antworten »

EDIT: Ich wollte jetzt mal mit der Konsole kompilieren, aber leider funktioniert das nicht. meine Datei befindet sich unter C:\Users\Chrisch\Documents\LATEX
und in der Konsole steht C:\Users\Chrisch>
was muss ich da genau eingeben?
Wenn ich das eingebe: C:\Users\Chrisch>"Documents\LATEX" oder das: C:\Users\Chrisch>cd"Documents\LATEX" kann der angegebene Pfad nicht gefunden werden:-(
Calvin Auf diesen Beitrag antworten »

Nein, das nützt nichts. Ich vermute mal, dass das der Output deiner Vorlage ist.

Ich würde dir trotzdem empfehlen, einmal auf der Konsole zu kompilieren (oder mit einem anderen Editor, z.B. Texworks). Außerdem könntest du im Paketmanager schauen, ob das Paket bbding bei dir installiert ist (Aufruf über das Windows-Startmenü).

Die beste Vorlage hilft allerdings nichts, wenn man das Grundsytem nicht verstanden hat. Deshalb empfehle ich dir, erst mal mit einem kleinen Stück Code anzufangen.

code:
1:
2:
3:
4:
\documentclass{article}
\begin{document}
Hallo Welt
\end{document}


Wenn das vollständig läuft, kannst du z.B mal die Zeile \usepackage{bbding} als zweite Zeile einfügen. Was passiert dann? Kompiliert es immer noch?

Den Text deiner eigentlichen Arbeit kannst du ja trotzdem schon mit einem kleinen Vorspann schreiben. Das ist ja gerade der große Vorteil von LaTeX, dass man sich zunächst vollkommen auf das Schreiben konzentrieren kann. Wenn dann anschließend irgendwelche Layout-Vorgaben kommen, kann man die bequem in der Präambel einfügen.

EDIT
Gib mal cd Documents\LATEX ein, um in den Ordner zu wechseln.
antjeprincipessa Auf diesen Beitrag antworten »

OK ich würde sagen, da haben wir den Fehler! Danke schonmal. Anscheinend liegt es an dem Paket. Die Frage ist jetzt nur, wie ich das Paket bekomme:-)

Dein Beispiel mit Hallo Welt habe ich auch schon vor ein paar Tagen gemacht und das klappt alles super. Einzig ihre doofe Vorlage will nicht:-)
antjeprincipessa Auf diesen Beitrag antworten »

So jetzt habe ich das usepackage installiert und nun sehe ich, dass ich wohl ersteinmal alle usepackages installieren muss, die meine Professorin verwendet:-(
Muss ich das alles einzeln machen oder gibt es da nen "Trick" wie ich alle auf einmal installiere?

Danke schon mal. Du/Sie bist/sind mir eine echt große Hilfe. Vor allem jetzt am Wochenende:-)
JUHU es klappt! Sorry für die Panikmache, aber es fehlten doch nur zwei packages und ich habe es vollbracht!!!!! Jetzt kann ich endlich loslegen! Ich freu mich so, mir fällt ein Stein vom Herzen.
Calvin Auf diesen Beitrag antworten »

Zitat:
Original von antjeprincipessa
Danke schon mal. Du/Sie bist/sind mir eine echt große Hilfe.


Das "du" ist hier üblich.

Mit der Miktex-Einstellung "Pakete on the fly installieren => yes" sollten fehlende Pakete beim Kompilieren eigentlich automatisch und ohne Rückfrage installiert werden. Warum das bei dir nicht klappt kann man aus der Ferne nur spekulieren. Wenn es nochmal auftreten sollte, solltest du dir die log-Datei des Kompiliervorgangs mal sichern. Eventuell findet sich dort ein Hinweis ob es Probleme beim Download oder der Installation gab.
Neue Frage »
Antworten »



Verwandte Themen

Die Beliebtesten »
Die Größten »
Die Neuesten »